Outage related to an issue with our advanced authentication servers
Incident Report for Digital Measures
Resolved
This incident has been resolved.
Posted Apr 11, 2019 - 10:24 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 11, 2019 - 10:21 CDT
Investigating
We are currently investigating this issue.
Posted Apr 11, 2019 - 10:20 CDT
This incident affected: Activity Insight, Workflow, and Self-Service Reporting.