Digital Measures Maintenance
Incident Report for Digital Measures
Resolved
Digital Measures has completed the scheduled maintenance. Thank you.
Posted Nov 23, 2018 - 22:45 CST
Monitoring
We are monitoring maintenance progress.
Posted Nov 23, 2018 - 22:03 CST
Investigating
Digital Measures is starting scheduled maintenance. Updates on the maintenance status will be posted to http://status.digitalmeasures.com
Posted Nov 23, 2018 - 22:02 CST
This incident affected: Activity Insight, Workflow, and Self-Service Reporting.